System Requirements

Minimum System Requirements

– Quad Core i5 Processor
– 4GB of RAM
– Mac OS X 10.7 or Later
– Windows 7 & Above
– iLok2 or 3 Required:

 iLok3-large.jpg31b_TDtNG1L.jpg

Note: The plugins will work with a duo core as long as the processor speed is sufficient, however for optimum performance we recommend a Quad Core i5 Processor or better. 

Recommended System Requirements

– Quad Core i7 Processor
– 8GB of RAM
– Mac OS X 10.9 or Later
– Windows 7 & Above
– iLok2 or 3 Required:

iLok3-large.jpg31b_TDtNG1L.jpg

Have more questions? Submit a request

Comments