System Requirements

MAC Minimum Requirements

  • Dual Core Intel Processor, At Least 4 GB of RAM
  • Mac OS X 10.6 or later
  • AU, VST2, RTAS and AAX
  • 32 and 64-bit 
  • (iLok1, iLok2, or iLok3 Required)

PC Minimum Requirements

  • Dual Core Intel or AMD Processor, At Least 4 GB RAM
  • Windows 7® (32/64-Bit) or above
  • VST2, RTAS and AAX
  • 32 and 64-bit
  • (iLok1, iLok2, or iLok3 Required)

 

Note: The supported plugin formats depend of the FG-X version. See more HERE.

Have more questions? Submit a request

Comments