Catalina Compatibility (Beta Installers)

The latest releases of our plugins are not compatible with macOS Catalina. We now have new plugin versions that are compatible in Logic Pro (and other DAWs) in Catalina, but these updates are not yet public. Please use the links below to install these new versions:

Virtual Mix Rack 2.4.7.8

VBC 1.2.14.5

VTM 1.1.16.3

VSC 1.0.12.5

FG-X 1.4.0.4_C

AirEQ Premium 1.1.11.3

e2deesser 1.0.9.3

The rest of the All Access Pass installers on our Installers page are already compatible with MacOS Catalina.

Note: These are beta installers, but should be working as expected. The installers also have finished QA so they're compatible in MacOS Catalina, but still need to be thoroughly tested in lower Mac operating systems.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.